Manjaro Linux - Forum Italiano

Problema con aggiornamento del sistema

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Problema con aggiornamento del sistema
« il: Marzo 29, 2020, 12:30:43 am »
Ciao a tutti,

chiedo scusa per il titolo molto generico, ma non sapevo come descrivere meglio il "problema". Ormai sono abituato ad aggiornare tutto il sistema tramite il software cleanupdate, ma non riesco piu' ad aggiornare il sistema in maniera "tradizionale". Ovviamente nessun problema dando nel terminale i comandi "pacman -Syy" e "pacman -Syu", ma ero abituato ad aggiornare cliccando sulla simpatica icona di pacman, nel vassoio di sistema.
Quell'icona mi segnala che ci sono tot aggiornamenti e, dopo aver cliccato su ok per installarli, mi chiede ovviamente la password. Inserendo la password il risultato che ottengo e' questo:

Codice: [Seleziona]
Avvio aggiornamento completo del sistema...

octopi-helper[aborted]: Suspicious execution method

Comando terminato con degli errori!

Questa cosa succede gia' da un paio di mesi. Mi dice che il metodo di esecuzione e' sospetto. Sembra una sorta di sistema di sicurezza, che probabilmente serve ad evitare l'installazione da parte di qualche programma malevolo. Ovviamente non capisco il perche' di questo e' ovviamente ignoro come poter risolvere il problema.
Vi e' mai capitato qualcosa del genere? Posso in qualche modo resettare le impostazioni di Octopi e sperare di risolvere il problema?
Al momento ho installati sia Pamac che Octopi, ma se non ricordo male Pamac e' solo un frontend di Octopi sviluppato da team Manjaro. Su Pamac ho abilitato i software da AUR, ma questi credo vengano aggiornati tramite Octopi, perche' mi pare che cleanupdate cerchi yaourt o programmi similari per gestire i pacchetti AUR.
Non sono sicurissimo che il software AUR sia aggiornato e come vedete ho un po' di confusione in testa, forse perche' su Ubuntu ero abituato all' aggiungi/rimuovi e al massimo a Synaptic, per gestire ogni singolo pacchetto.
Mi trovo comunque molto bene su Manjaro e pian piano mi sono adattato alle piccole differenze, e anche alle gradevoli aggiunte che me lo hanno fatto preferire rispetto ad altri.

A presto, grazie a tutti voi.  ;)

Raffaele

Raffaele

Manjaro Linux KDE su GPD Pocket 2 con Intel m3-8100y e Intel UHD 615
Manjaro Linux KDE su Asus Rog Strix Z390-F Gaming, Intel i7 9700k, Nvidia 2080Ti

D-BARTO

  • *****
  • 1356
  • Rolling User
Re:Problema con aggiornamento del sistema
« Risposta #1 il: Marzo 29, 2020, 10:11:18 am »
Ciao
Da quanto non aggiorni?
prova da terminale uno alla volta e vedi cosa dice
Codice: [Seleziona]
sudo pacman-mirrors -f 10
sudo pacman -Syyu
Penso dunque sono acceso  :)
Rolling User: Manjaro 64bit Kde Plasma,Mate,Xfce--PCLinuxOS 64 bit Mate
---------------------------------------------------------------
Intel Core i3-3217U CPU 1.80GHz 4  Intel 3rd Gen Core processor Graphics
e AMD E2-7110 APU-AMD Radeon R2 Graphics  4x 1.8GHz

Cubanpit

  • *****
  • 2904
    • pitNtip
Re:Problema con aggiornamento del sistema
« Risposta #2 il: Marzo 29, 2020, 02:33:45 pm »
Se ho capito bene tutto funziona aggiornando da terminale, ma non funziona provando ad aggiornare dall'icona nel vassoio di sistema.
Immagino tu sia su KDE visto che hai Octopi.
Pamac un'alternativa a pacman dotata di interfaccia grafica, gestisce per conto suo i pacchetti e AUR e non dipende da altri software.
Octopi una volta un'interfaccia per pamac e altri software (Yay o Trizen), quindi dipende su questi software per alcune funzioni.
In teoria ogni metodo dovrebbe funzionare, se dall'icona non funziona correttamente prova semplicemente ad aprire Octopi o Pamac e usarli direttamente.
Tra l'altro mi verrebbe da dire che uno dei due superfluo, offrono le stesse funzionalit con interfacce leggermente diverse, Pamac un poco pi rifinito e gestito direttamente da Manjaro, ma sei libero di scegliere quel che preferisci.

Re:Problema con aggiornamento del sistema
« Risposta #3 il: Marzo 29, 2020, 05:53:18 pm »
Buongiorno ragazzi,

grazie delle risposte!

D-BARTO: aggiorno spesso manualmente tramite cleanupdate. Quando non aggiorno ma sono disponibili aggiornamenti, comunque mi vengono segnalati del vassoio di sistema. Di solito aggiorno subito i pacchetti appena vengono rilasciati. Recentemente ero in trepidante attesa di ricevere l'aggiornamento della nuova versione di Plasma, che funziona meglio della precedente.
Dopo lancio i comandi che mi hai chiesto e ti posto i risultati.

Pietro: grazie come sempre. Si', hai centrato il punto, ovvero stranamente non posso piu' aggiornare dal vassoio di sistema. In qualche modo subentra un qualche sistema di protezione. Ovviamente non e' un dramma, perche' posso aggiornare in mille altri modi, ma ero curioso di sapere se a qualcuno di voi fosse successo.
Allora, a quanto ho capito sia Octopi che Pamac si collegano a Pacman ed entrambi svolgono la stessa funzione. A quanto ho capito Octopi e' uno strumento specifico di KDE Plasma, ho capito bene?
Francamente ho l'abitudine ad usare Pamac, che graficamente mi piace di piu' ed e' organizzato meglio (a mio gusto). Se ho capito bene potrei tranquillamente disinstallare Octopi e usare solo Pamac. Chiedo conferma.  ;)

Utilizzo solo Manjaro con KDE Plasma e il pc sul quale lo sto usando e' quello in firma, precisamente il primo, ovvero il GPD Pocket 2. Ho seguito il consiglio di D-BARTO e ho inserito le caratteristiche base dei miei sistemi in firma.

Buona serata.  ;)
Raffaele

Manjaro Linux KDE su GPD Pocket 2 con Intel m3-8100y e Intel UHD 615
Manjaro Linux KDE su Asus Rog Strix Z390-F Gaming, Intel i7 9700k, Nvidia 2080Ti

Re:Problema con aggiornamento del sistema
« Risposta #4 il: Marzo 29, 2020, 05:57:18 pm »
Codice: [Seleziona]
[raffaele@raffaele-gpd ~]$ sudo pacman-mirrors -f 10
[sudo] password di raffaele:
::INFO Scaricamento in corso dei mirror da repo.manjaro.org
::INFO Viene utilizzato il file dei mirror predefinito
::INFO Interrogazione in corso dei mirror - Questa operazione potrebbe richiedere del tempo
  0.767 Germany        : https://ftp.halifax.rwth-aachen.de/manjaro/
  0.803 Germany        : ftp://ftp.halifax.rwth-aachen.de/manjaro/
  0.606 Bulgaria       : http://manjaro.telecoms.bg/
  ..... Hong_Kong      : http://ftp.cuhk.edu.hk/pub/Linux/manjaro/
  ..... Hong_Kong      : ftp://ftp.cuhk.edu.hk/pub/Linux/manjaro/
  0.816 Russia         : http://mirror.truenetwork.ru/manjaro/
  0.528 Hungary        : https://quantum-mirror.hu/mirrors/pub/manjaro/
  0.310 Hungary        : http://quantum-mirror.hu/mirrors/pub/manjaro/
  1.432 Costa_Rica     : https://mirrors.ucr.ac.cr/manjaro/
  ..... Australia      : http://manjaro.mirror.serversaustralia.com.au/
  0.509 Spain          : https://ftp.caliu.cat/pub/distribucions/manjaro/
  0.371 Spain          : http://ftp.caliu.cat/pub/distribucions/manjaro/
  1.081 United_States  : https://mirrors.gigenet.com/manjaro/
  0.780 United_States  : http://mirrors.gigenet.com/manjaro/
  0.604 Italy          : https://ba.mirror.garr.it/mirrors/manjaro/
::INFO Scrittura in corso della mirrorlist
::Hungary         : https://quantum-mirror.hu/mirrors/pub/manjaro/stable
::Spain           : https://ftp.caliu.cat/pub/distribucions/manjaro/stable
::Italy           : https://ba.mirror.garr.it/mirrors/manjaro/stable
::Bulgaria        : http://manjaro.telecoms.bg/stable
::United_States   : https://mirrors.gigenet.com/manjaro/stable
::Germany         : https://ftp.halifax.rwth-aachen.de/manjaro/stable
::Russia          : http://mirror.truenetwork.ru/manjaro/stable
::Costa_Rica      : https://mirrors.ucr.ac.cr/manjaro/stable
::Australia       : http://manjaro.mirror.serversaustralia.com.au/stable
::Hong_Kong       : http://ftp.cuhk.edu.hk/pub/Linux/manjaro/stable
::INFO La lista dei mirror stata generata e salvata in: /etc/pacman.d/mirrorlist
[raffaele@raffaele-gpd ~]$ sudo pacman -Syyu
:: Sincronizzazione dei database in corso...
 core                               171,5 KiB  1350 KiB/s 00:00 [###################################] 100%
 extra                             1999,0 KiB  7,23 MiB/s 00:00 [###################################] 100%
 community                            5,9 MiB  5,63 MiB/s 00:01 [###################################] 100%
 multilib                           192,4 KiB  26,8 MiB/s 00:00 [###################################] 100%
:: Aggiornamento del sistema in corso...
 non ci sono aggiornamenti disponibili
[raffaele@raffaele-gpd ~]$

Grazie D-BARTO.  ;)
Non sono abituato a dare questi comandi, ma sono senz'altro integrati nello strumento cleanupdate. Ho fatto un po' di confusione perche' utilizzo fin troppi strumenti per gestire i software e non mi era del tutto chiara la gerarchia.
Dopo la vostra conferma eliminero' Octopi, se effettivamente Pamac svolge lo stesso compito.

Buona serata.
Raffaele

Manjaro Linux KDE su GPD Pocket 2 con Intel m3-8100y e Intel UHD 615
Manjaro Linux KDE su Asus Rog Strix Z390-F Gaming, Intel i7 9700k, Nvidia 2080Ti

max deal

  • *****
  • 1467
  • The dark side of the moon
Re:Problema con aggiornamento del sistema
« Risposta #5 il: Marzo 29, 2020, 08:40:33 pm »
Personalmente ho installato kde su disco esterno insieme ad altri de ,io ho installato nel  sistema sin dall'inizio pamac e non octopi .
Un augurio di una vita serena e tranquilla.

manjaro xfce
Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP
  L2 cache: 4096 KiB
AMD Park [Mobility Radeon HD 5430] driver: radeon v: kernel

max deal

  • *****
  • 1467
  • The dark side of the moon
Re:Problema con aggiornamento del sistema
« Risposta #6 il: Marzo 29, 2020, 08:42:01 pm »
E non l'ho installato io .
Un augurio di una vita serena e tranquilla.

manjaro xfce
Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP
  L2 cache: 4096 KiB
AMD Park [Mobility Radeon HD 5430] driver: radeon v: kernel

Re:Problema con aggiornamento del sistema
« Risposta #7 il: Marzo 29, 2020, 10:46:07 pm »
In che senso hai installato KDE su disco esterno? Non mi e' molto chiaro. Stai parlando del DE oppure di tutto il sistema?
Io ho installato il sistema direttamente con KDE Plasma (ho scaricato la iso specifica) e sinceramente ho messo tutto in un'unica partizione sul disco interno principale, non avendo mai capito come gestire gli spazi.
Mi piacerebbe riprovare anche Gnome, ma per questo preferisco aprire un altro topic eventualmente, oppure posso lanciare una live con Gnome, evitando di installare qualunque cosa.
Potrei sbagliarmi, ma a me sembra di ricordare che Octopi fosse gia' presente alla prima installazione del sistema, mentre Pamac l'ho dovuto installare manualmente. Uso sempre Pamac quindi, a quanto ho capito, Octopi potrei benissimo rimuoverlo.
Raffaele

Manjaro Linux KDE su GPD Pocket 2 con Intel m3-8100y e Intel UHD 615
Manjaro Linux KDE su Asus Rog Strix Z390-F Gaming, Intel i7 9700k, Nvidia 2080Ti

m3nhir

  • ***
  • 141
Re:Problema con aggiornamento del sistema
« Risposta #8 il: Marzo 29, 2020, 11:35:14 pm »
Anche io ho lo stesso errore quando faccio partire l'aggiornamento dall'icona di octopi, sul vassoio di sistema (uso kde). :(
La cosa ha stupito anche me i quanto aggiornando da terminale con pacman non mi segnala errori e l'aggiornamento va sempre a buon fine. Provero ad installare pamac e disinstallare octopi e verificare se l'errore persiste.  8)
Linux User # 207701 - L'intelligenza non non commettere errori, ma scoprire subito il modo di trarne profitto.

max deal

  • *****
  • 1467
  • The dark side of the moon
Re:Problema con aggiornamento del sistema
« Risposta #9 il: Marzo 30, 2020, 12:17:09 am »
In che senso hai installato KDE su disco esterno? Non mi e' molto chiaro. Stai parlando del DE oppure di tutto il sistema?
Io ho installato il sistema direttamente con KDE Plasma (ho scaricato la iso specifica) e sinceramente ho messo tutto in un'unica partizione sul disco interno principale, non avendo mai capito come gestire gli spazi.
Mi piacerebbe riprovare anche Gnome, ma per questo preferisco aprire un altro topic eventualmente, oppure posso lanciare una live con Gnome, evitando di installare qualunque cosa.
Potrei sbagliarmi, ma a me sembra di ricordare che Octopi fosse gia' presente alla prima installazione del sistema, mentre Pamac l'ho dovuto installare manualmente. Uso sempre Pamac quindi, a quanto ho capito, Octopi potrei benissimo rimuoverlo.

Sull'hard disk principale sda per intenderci ho installato manjaro xfce ,cinnamoon e budgie , mentre sul disco sdb esterno ho installato manjaro gnome e mate e kde , parlo di sistemi completi , ciao.
Un augurio di una vita serena e tranquilla.

manjaro xfce
Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP
  L2 cache: 4096 KiB
AMD Park [Mobility Radeon HD 5430] driver: radeon v: kernel

D-BARTO

  • *****
  • 1356
  • Rolling User
Re:Problema con aggiornamento del sistema
« Risposta #10 il: Marzo 30, 2020, 09:36:49 am »
Anch'io come max ho kde e adesso lo uso come principale. (installato con l'ultima iso disponibile) su hd interno.
octopi non so nemmeno cosa sia se non per sentito dire.(e non presente nel sistema)

E' probabile che pamac sia pi versatile, e poi comune a tutti i DE per questo forse stato scelto anche per l'ultimo kde.
Chi ha kde da molto tempo e avendo gi un gestore(octopi), il sistema aggiorni sempre quello e qualsiasi altro va  installato volontariamente.
« Ultima modifica: Marzo 30, 2020, 10:42:05 am da D-BARTO »
Penso dunque sono acceso  :)
Rolling User: Manjaro 64bit Kde Plasma,Mate,Xfce--PCLinuxOS 64 bit Mate
---------------------------------------------------------------
Intel Core i3-3217U CPU 1.80GHz 4  Intel 3rd Gen Core processor Graphics
e AMD E2-7110 APU-AMD Radeon R2 Graphics  4x 1.8GHz

Cubanpit

  • *****
  • 2904
    • pitNtip
Re:Problema con aggiornamento del sistema
« Risposta #11 il: Aprile 02, 2020, 03:25:06 pm »
Octopi un'interfaccia a pacman, maggiori informazioni sul sito. Non legato al progetto Manjaro.

Pamac un'alternativa a pacman, l'unico sito di riferimento la Wiki di Manjaro, visto che la documentazione e la comunicazione non sono il punto forte del team.  >:D
Quest'ultimo un progetto ufficiale di Manjaro ed ora installato in ogni versione ufficiale di Manjaro.
Saltuariamente, negli annunci sul forum internazionale, viene ancora consigliato di aggiornare il sistema con pacman, perch Pamac non ha ancora raggiunto la perfezione.